各语言对应版本和环境

力扣发表于:2018年10月26日 早上 00:30:16更新于:2020年10月26日 早上 10:50:47

语言版本详细
C++g++ 8.2C++14 标准
Javajava 1.8.0
Pythonpython 2.7.12
Python3Python 3.6.7
MySQLmysql-server 5.7.21
Cgcc 8.2您可以使用 uthash 来操作哈希表。
"uthash.h" 已经被默认包含了。
C#mono 5.18.0/debug 标记执行,使用 C# 7 的完整支持
JavaScriptnodejs 10.15.0使用 --harmony 标记执行,开启 ES6 功能
lodash.js 库已经被默认包含了。
Rubyruby 2.4.5
Rust1.31.0edition = 2018,支持 crates.io 的 rand
Bashbash 4.3.30
Swiftswift 4.2
Gogo 1.11.4
ScalaScala 2.11.6
KotlinKotlin 1.2.50
PHPPHP 7.2

回复(24)

  • kotlin

    要是kotlin版本能升级到1.3就好了

  • ryangle

    C Sharp 用最新的 DotNet Core 就好了

  • SolomonSun2010

    java 1.8.0 太低了,Java 12已经发布了,它有个显著好处,是直接运行单个源文件而无需编译,特别适于这种解题。

    同样Scala和kotlin也太低了,建议升级到:

    ScalaScala 2.13
    KotlinKotlin 1.3增加协程库coroutines 1.x


  • 力扣

    非常感谢大家的反馈,我们会持续更新,有什么希望兼容增加的大家都可以在这里提建议。

    引用 SolomonSun2010 的回复:

    java 1.8.0 太低了,Java 12已经发布了,它有个显著好处,是直接运行单个源文件而无需编译,特别适于这种解题。同样Scala和kotlin也太低了,建议升级到:ScalaScala 2.13KotlinKotlin 1.3增加协程库coroutines 1.x

  • 七月流火

    C++ 建议使用 C++ 17 标准, Swift 建议升级到 Swift 5.

  • 七月流火

    另外, Java, Kotlin, Scala 的版本也太低, 如上面 @SolomonSun2010 的评论所说.

  • SakuraWong

    建议增加common lisp或者scheme

  • young40

    希望可以支持Lua

  • 郑天乐

    OptionalInt result =  Arrays.stream(nums).reduce((a, b) -> (a ^ b));

    java8 cannot find symbol???

  • 王宇翔

    c++不说20了,支持17不过分吧

  • HaKu

    Kotlin求升级...

  • barrentear

    common lisp 来一个:)

  • 杰水 余

    希望 scala 升级到2.13 :)

  • 黄剑

    可以支持下 Nim 语言

  • 栗子球

    希望能支持Objective-C

  • user1676t

    scala 升级到2.13

  • 01NoMagic

    请问下c++语言默认导入了哪些标准库呢?

  • 郁巷(宇航请不要这样)

    请问c编译环境变了么?编译命令是什么?

  • Bowman han

    能不能支持ocaml

  • liuhuo01scala

    能否更新一下这里的文档? 我试了一下, 

    Java 已经更新到了 13 (Runtime.getRuntime().version()), 

    Kotlin 已经更新到了 1.3.x (inner class in annotation class),

    Scala 已经至少更新到了 2.12 (mutable TreeMap),

    C++ 也更新到了 C++ 17 标准 (#include<optional>).

    可能跟美国 LeetCode 是同步的环境.

  1. 1
  2. 2
  3. 末页 >>